source: trunk/default.nix

Last change on this file was 7e972e4, checked in by Jean-Paul Calderone <exarkun@…>, at 2023-07-21T14:24:09Z

further clarifying comments

  • Property mode set to 100644
File size: 506 bytes
Line 
1# This is the flake-compat glue code.  It loads the flake and gives us its
2# outputs.  This gives us backwards compatibility with pre-flake consumers.
3# All of the real action is in flake.nix.
4(import
5  (
6    let lock = builtins.fromJSON (builtins.readFile ./flake.lock); in
7    fetchTarball {
8      url = "https://github.com/edolstra/flake-compat/archive/${lock.nodes.flake-compat.locked.rev}.tar.gz";
9      sha256 = lock.nodes.flake-compat.locked.narHash;
10    }
11  )
12  { src = ./.; }
13).defaultNix.default
Note: See TracBrowser for help on using the repository browser.