source: trunk/nix/tahoe-lafs.nix

Last change on this file was 9570e4b, checked in by meejah <meejah@…>, at 2024-01-05T03:13:35Z

update nix

  • Property mode set to 100644
File size: 1.4 KB
Line 
1let
2  pname = "tahoe-lafs";
3  version = "1.19.0.post1";
4in
5{ lib
6, pythonPackages
7, buildPythonPackage
8, tahoe-lafs-src
9}:
10buildPythonPackage rec {
11  inherit pname version;
12  src = tahoe-lafs-src;
13  propagatedBuildInputs = with pythonPackages; [
14    attrs
15    autobahn
16    cbor2
17    click
18    collections-extended
19    cryptography
20    distro
21    eliot
22    filelock
23    foolscap
24    future
25    klein
26    magic-wormhole
27    netifaces
28    psutil
29    pyyaml
30    pycddl
31    pyrsistent
32    pyutil
33    six
34    treq
35    twisted
36    werkzeug
37    zfec
38    zope_interface
39  ] ++
40  # Get the dependencies for the Twisted extras we depend on, too.
41  twisted.passthru.optional-dependencies.tls ++
42  twisted.passthru.optional-dependencies.conch;
43
44  # The test suite lives elsewhere.
45  doCheck = false;
46
47  passthru = {
48    extras = with pythonPackages; {
49      tor = [
50        txtorcon
51      ];
52      i2p = [
53        txi2p
54      ];
55      unittest = [
56        beautifulsoup4
57        html5lib
58        fixtures
59        hypothesis
60        mock
61        prometheus-client
62        testtools
63      ];
64      integrationtest = [
65        pytest
66        pytest-twisted
67        paramiko
68        pytest-timeout
69      ];
70    };
71  };
72
73  meta = with lib; {
74    homepage = "https://tahoe-lafs.org/";
75    description = "secure, decentralized, fault-tolerant file store";
76    # Also TGPPL
77    license = licenses.gpl2Plus;
78  };
79}
Note: See TracBrowser for help on using the repository browser.