﻿id	summary	reporter	owner	description	type	status	priority	milestone	component	version	resolution	keywords	cc	launchpad_bug
769	have buildslaves automatically build debian packages of foolscap, zfec, pycryptopp, pyutil, argparse, zbase32	warner	nobody	"I just tried to run {{{tahoe --version}}} from a .deb I built from trunk (on my sid system), and it fails with the following error:

{{{
pkg_resources.VersionConflict: (pycryptopp 0.5.2-1 (/usr/lib/python2.5/site-packages), Requirement.parse('pycryptopp>=0.5.15'))
}}}

I've updated the debian/control files to make this requirement visible to the debian package manager (i.e. it should not let me install this tahoe), but apart from that, we need updated pycryptopp debs before we can release 1.5.0 . We need them for all of the same platforms for which we provide Tahoe debs: etch/edgy/feisty/gutsy/hardy/hardy-amd64 .

I think we're ok with zfec and foolscap packages.
"	defect	closed	critical	eventually	packaging	1.4.1	invalid	debian ubuntu foolscap zfec pycryptopp pyutil argparse zbase32 install	blackdew@… bdew exarkun	
