source: trunk/nix/service-identity.nix

Last change on this file was 94e608f1, checked in by Jean-Paul Calderone <exarkun@…>, at 2023-07-07T14:02:52Z

more python package tweaks

also point nixpkgs-unstable at HEAD of a PR with a cryptography upgrade
I tried just overriding the upgrade into place but it results in infinite
recursion, I suppose because cryptography is a dependency of some of the build
tools and needs extra handling that I don't feel like figuring out for this
short-term hack. someday the upgrade will land in nixpkgs master and we can
switch back.

  • Property mode set to 100644
File size: 1.1 KB
Line 
1{ lib
2, attrs
3, buildPythonPackage
4, cryptography
5, fetchFromGitHub
6, hatch-fancy-pypi-readme
7, hatch-vcs
8, hatchling
9, idna
10, pyasn1
11, pyasn1-modules
12, pytestCheckHook
13, pythonOlder
14, setuptools
15}:
16
17buildPythonPackage rec {
18  pname = "service-identity";
19  version = "23.1.0";
20  format = "pyproject";
21
22  disabled = pythonOlder "3.8";
23
24  src = fetchFromGitHub {
25    owner = "pyca";
26    repo = pname;
27    rev = "refs/tags/${version}";
28    hash = "sha256-PGDtsDgRwh7GuuM4OuExiy8L4i3Foo+OD0wMrndPkvo=";
29  };
30
31  nativeBuildInputs = [
32    hatch-fancy-pypi-readme
33    hatch-vcs
34    hatchling
35    setuptools
36  ];
37
38  propagatedBuildInputs = [
39    attrs
40    cryptography
41    idna
42    pyasn1
43    pyasn1-modules
44  ];
45
46  nativeCheckInputs = [
47    pytestCheckHook
48  ];
49
50  pythonImportsCheck = [
51    "service_identity"
52  ];
53
54  meta = with lib; {
55    description = "Service identity verification for pyOpenSSL";
56    homepage = "https://service-identity.readthedocs.io";
57    changelog = "https://github.com/pyca/service-identity/releases/tag/${version}";
58    license = licenses.mit;
59    maintainers = with maintainers; [ fab ];
60  };
61}
Note: See TracBrowser for help on using the repository browser.