#1583 closed defect (duplicate)

Failure: allmydata.mutable.common.UncoordinatedWriteError

Reported by: killyourtv Owned by: kevan
Priority: critical Milestone: undecided
Component: unknown Version: 1.9.0
Keywords: UncoordinatedWriteError ucwe regression Cc: zooko
Launchpad Bug:


I have patched my installation of tahoe 1.9.0 with the patch from ticket #1010 (which worked perfectly with v1.8.3) for use on the I2P network.

Trying to repair my share I get the following error:

$ tahoe check --repair tahoe:
ERROR: 500 Internal Server Error
"Traceback (most recent call last):\x0aFailure: allmydata.mutable.common.UncoordinatedWriteError: \x0a"

This error will show no matter how many times the command is re-run. (I tried re-running it 10 times and the error came up each time).

After reverting back to v1.8.3:

$ tahoe check --repair tahoe:
Summary: not healthy
 storage index: ft4svdmjfm5th3sunuh6hhfcma
 good-shares: 4 (encoding is 3-of-10)
 wrong-shares: 5
 repair successful

Running the command again:

$ tahoe check --repair tahoe:
Summary: healthy
 storage index: ft4svdmjfm5th3sunuh6hhfcma
 good-shares: 10 (encoding is 3-of-10)
 wrong-shares: 0

A deep-check is currently running on the share using v1.8.3.

The used packages:

foolscap: 0.6.2,
pycryptopp: 0.5.29,
zfec: 1.4.22,
Twisted: 11.0.0,
Nevow: 0.10.0,
zope.interface: unknown,
python: 2.7.2+,
platform: Linux-debian_wheezy/sid-x86_64-64bit_ELF,
pyOpenSSL: 0.13,
simplejson: 2.2.0,
pycrypto: 2.4,
pyasn1: unknown,
mock: 0.7.2,
sqlite3: 2.6.0 [sqlite 3.7.9],
setuptools: 0.6 [distribute]

Please let me know if any other info would be of use.

Attachments (1)

incident-2011-11-19--00-37-24Z-5dwoh6q.flog.bz2 (20.7 KB) - added by killyourtv at 2011-11-19T15:49:28Z.
Incident report immediately after receiving an UncoordinatedWriteError? during a repair operation

Download all attachments as: .zip

Change History (12)

comment:1 Changed at 2011-11-16T00:17:30Z by killyourtv

...and for what it's worth, the deep-check on this share ultimately failed but at least some of it could be repaired.

comment:2 Changed at 2011-11-18T00:07:32Z by killyourtv

Correction: Of course I mean the patches in #1007 and #1010 (not just #1010 like I initially wrote)

comment:3 Changed at 2011-11-18T11:38:06Z by killyourtv

  • Keywords I2P ticket1010 http_proxy removed

comment:4 Changed at 2011-11-19T02:51:42Z by zooko

  • Owner changed from nobody to kevan

Hi killyourtv, I just saw this ticket for the first time. This sounds like a serious regression! Thank you for the bug report. Adding Cc: kevan in case he also hasn't noticed this ticket yet.

Could you look for incidents report files in the ~/.tahoe/logs/incidents directory next time this happens? (I.e. after reproducing it)

Also, you could push the "Report an Incident" button on the welcome page immediately after triggering the problem? That will produce another incident report file.

comment:5 Changed at 2011-11-19T02:51:57Z by zooko

  • Keywords ucwe regression added
  • Priority changed from major to critical

comment:6 Changed at 2011-11-19T02:53:29Z by zooko

Hm... this issue sounds familiar. Searching for tickets tagged ucwe I find #893 and #540. Your issue probably can't be exactly either of these, because it doesn't happen with v1.8.3. Still, it might be related to one of those, so a debugger might want to study them.

comment:7 Changed at 2011-11-19T02:58:54Z by zooko

  • Version changed from 1.9.0b1 to 1.9.0

Changed at 2011-11-19T15:49:28Z by killyourtv

Incident report immediately after receiving an UncoordinatedWriteError? during a repair operation

comment:8 Changed at 2011-11-19T15:58:08Z by killyourtv

The attached file incident-2011-11-19--00-37-24Z-5dwoh6q.flog.bz2 was from yesterday, created via the "Report a Problem" button (and stashed into another directory) within (IIRC) a few seconds of the failure.

comment:9 Changed at 2011-11-19T16:47:30Z by zooko

  • Cc zooko added

comment:10 Changed at 2011-12-01T10:40:31Z by killyourtv

Seems to have been fixed by the patch in #1628

Last edited at 2011-12-13T22:55:40Z by killyourtv (previous) (diff)

comment:11 Changed at 2011-12-13T22:56:05Z by killyourtv

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.