#660 closed defect (fixed)

debian packages require python < 2.6, but should allow python 2.6

Reported by: zooko Owned by: warner
Priority: major Milestone: 1.4.1
Component: website Version: 1.3.0
Keywords: Cc: tahoe-dev@…
Launchpad Bug:


There was a time when there was a bug in Tahoe when used with Python 2.6. I forget the details -- maybe it had to do with Nevow using "with" as a variable name? Possibly there was more than one. Anyway, that time is long past, as we have a python 2.6 buildbot which has been consistently happy for a long time. So our deb packages should relax their requirements from python < 2.6 to python <= 2.6 (or possibly python >= 2.4.2 && python < 3?)

Dash can't install the deb's on Ubuntu 9.04 because some other packages (gobject-introspection, compiz, gimp require python >= 2.6.

Change History (2)

comment:1 Changed at 2009-03-11T15:12:44Z by zooko

https://bugs.launchpad.net/allmydata.org/+bug/341168 # please be compatible with python 2.5

comment:2 Changed at 2009-03-18T02:07:46Z by zooko

  • Resolution set to fixed
  • Status changed from new to closed

fixed in 55de7c3fed797b0e

Note: See TracTickets for help on using tickets.