#74 closed defect (fixed)

Confusing UI Terminology: "Add Shared Directory"

Reported by: nejucomo Owned by: nejucomo
Priority: minor Milestone: eventually
Component: code-frontend-web Version: 0.4.0
Keywords: usability Cc:
Launchpad Bug:


What does "Add Shared Directory" do?

Is the "Name to place incoming directory" a path on the vdrive or my client's filesystem?

Does "Mount shared directory" create a new mount binding on my client's filesystem?

Change History (7)

comment:1 Changed at 2007-07-02T19:28:39Z by warner

good things to fix

Really this is "add URI as a child of the given name", where the URI could either point to a directory or to a single file. I used the words "Add Shared Directory" to match the text at the top of each directory page that offers the URI for that directory, to give people the idea that you cut from one and paste into the other.

"Name to place incoming directory" is a single pathname component (no slashes) and means that we will create a child of the current directory with that name. The child will point to the thing being linked. This is the equivalent of 'cp ... ./Name', or 'ln -s ... ./Name', or 'mount ... ./Name'. This is completely unrelated to the disk-based filesystem of the host on which your client is running.

'Mount shared directory' does not touch the disk-based filesystem of your client's host. It only affects your vdrive.

The only thing which touches the your host's disk is the upload file button.

Now, how to summarize all of these notes into a concise and expressive webish.py directory page.

Also, note that eventually we will have professional web UI designers replace this. webish.py is purely an engineering interface, so I feel it's ok if it requires a bit of engineering explanation to understand completely.

comment:2 Changed at 2007-07-02T19:47:01Z by warner

  • Milestone set to release 0.5.0

comment:3 Changed at 2007-07-16T19:21:24Z by warner

  • Owner changed from somebody to nejucomo

The current box is labeled "Attach a file or directory (by URI) to this directory", and has two boxes, labeled "New child name:" and "URI of new child:".

Is this any better?

comment:4 Changed at 2007-07-16T19:21:37Z by warner

  • Priority changed from major to minor

comment:5 Changed at 2007-08-14T18:56:38Z by warner

  • Component changed from code to code-frontend-web

comment:6 Changed at 2007-08-15T18:31:27Z by warner

  • Milestone changed from 0.5.0 to undecided

comment:7 Changed at 2007-08-17T00:53:19Z by nejucomo

  • Resolution set to fixed
  • Status changed from new to closed

The current labels make much more sense to me. After seeing them, the old labels also make sense, but I think these are much easier to comprehend off the bat.

Closing this.

Note: See TracTickets for help on using tickets.