#1556 closed defect (fixed)

fix bugs found by 'check-miscaptures' script

Reported by: davidsarah Owned by: warner
Priority: major Milestone: 1.9.0
Component: code Version: 1.9.0a2
Keywords: miscapture regression Cc:
Launchpad Bug:

Description

These are the bugs that were found in trunk.

Attachments (2)

1556-fix-miscaptures.darcs.patch (15.5 KB) - added by davidsarah at 2011-10-07T03:49:42Z.
Fix some potential bugs exposed by check-miscaptures.py. (Version 3.)
1556-suppress-warnings.darcs.patch (24.5 KB) - added by davidsarah at 2011-10-09T19:26:02Z.
Fix false positives.

Download all attachments as: .zip

Change History (18)

Changed at 2011-10-07T03:49:42Z by davidsarah

Fix some potential bugs exposed by check-miscaptures.py. (Version 3.)

comment:1 Changed at 2011-10-07T03:59:31Z by davidsarah

  • Keywords regression review-needed added
  • Owner changed from somebody to warner

Note that this is wanted for 1.9beta; the changes in src/allmydata/mutable/servermap.py are to fix bugs introduced by MDMF in changeset bb10d685ed86eb08, so potential regressions.

comment:2 Changed at 2011-10-07T19:39:47Z by david-sarah@…

In [5396/ticket999-S3-backend]:

misc/simulators/hashbasedsig.py: simplify by removing unnecessary local function that captured a variable declared in a for loop (this was not a bug, but the code was unclear). Also fix a pyflakes warning about an import. refs #1556

comment:3 Changed at 2011-10-07T19:39:48Z by david-sarah@…

In [5397/ticket999-S3-backend]:

Fix some potential bugs in test code exposed by check-miscaptures.py. refs #1556

comment:4 Changed at 2011-10-07T19:39:48Z by david-sarah@…

In [5398/ticket999-S3-backend]:

Fix some potential bugs (in non-test code) exposed by check-miscaptures.py. refs #1556

comment:5 Changed at 2011-10-07T19:39:48Z by david-sarah@…

In [5399/ticket999-S3-backend]:

Fix some more potential bugs in test code exposed by check-miscaptures.py. refs #1556

Changed at 2011-10-09T19:26:02Z by davidsarah

Fix false positives.

comment:6 Changed at 2011-10-10T19:53:52Z by david-sarah@…

In bc0d9b682e97c26d:

misc/simulators/hashbasedsig.py: simplify by removing unnecessary local function that captured a variable declared in a for loop (this was not a bug, but the code was unclear). Also fix a pyflakes warning about an import. refs #1556

comment:7 Changed at 2011-10-12T21:47:36Z by david-sarah@…

In [5435/ticket999-S3-backend]:

misc/coding_tools/make-canary-files.py: fix a suspicious capture reported by check-miscaptures (although it happens not to be a bug because the callback will be processed synchronously). refs #1556

comment:8 Changed at 2011-10-12T21:47:39Z by david-sarah@…

In [5436/ticket999-S3-backend]:

util/happinessutil.py: suppress a warning from check-miscaptures. (It is not a bug because the capturing function is only used by a 'map' in the same iteration.) refs #1556

comment:9 Changed at 2011-10-13T16:55:38Z by david-sarah@…

In 11ce612589cefd1f:

Fix some potential bugs in test code exposed by check-miscaptures.py. refs #1556

comment:10 Changed at 2011-10-13T16:55:38Z by david-sarah@…

In bdfa7b377226ffb5:

Fix some potential bugs (in non-test code) exposed by check-miscaptures.py. refs #1556

comment:11 Changed at 2011-10-13T16:55:38Z by david-sarah@…

In a31a701e42d46083:

Fix some more potential bugs in test code exposed by check-miscaptures.py. refs #1556

comment:12 Changed at 2011-10-13T16:55:39Z by david-sarah@…

In 22da015dd1f63e24:

misc/coding_tools/make-canary-files.py: fix a suspicious capture reported by check-miscaptures (although it happens not to be a bug because the callback will be processed synchronously). refs #1556

comment:13 Changed at 2011-10-13T16:55:39Z by david-sarah@…

In 3142538b0d4dd354:

util/happinessutil.py: suppress a warning from check-miscaptures. (It is not a bug because the capturing function is only used by a 'map' in the same iteration.) refs #1556

comment:14 Changed at 2011-10-13T16:56:42Z by warner

those look safe.. landed to trunk for 1.9. Are there others remaining, or can we close this ticket?

comment:15 Changed at 2011-10-13T19:41:00Z by davidsarah

  • Resolution set to fixed
  • Status changed from new to closed

comment:16 Changed at 2011-10-13T19:46:33Z by davidsarah

  • Keywords review-needed removed
Note: See TracTickets for help on using tickets.