#785 closed defect (invalid)

lenny (onwards) packages should depend on python-pysqlite2 not python-sqlite2

Reported by: arthur Owned by: zooko
Priority: major Milestone: eventually
Component: packaging Version: 1.5.0
Keywords: debian Cc:
Launchpad Bug:


python-sqlite2 has been renamed to python-pysqlite2 so from lenny onwards the dependency has to be changed.

BTW, I got to install the etch package on a lenny by doing the following :

wget http://allmydata.org/debian/dists/etch/tahoe/binary-i386/allmydata-tahoe_1.5.0-r4044_all.deb dpkg -i --ignore-depends=python-sqlite2 allmydata-tahoe_1.5.0_all.deb

Change History (5)

comment:1 Changed at 2009-08-11T22:35:53Z by warner

  • Component changed from unknown to packaging
  • Keywords debian added
  • Owner changed from nobody to somebody

comment:2 Changed at 2009-10-26T20:27:53Z by zooko

  • Owner changed from somebody to zooko
  • Status changed from new to assigned

Hm, misc/lenny/debian/control and misc/sid/debian/control don't mention sqlite at all. What's the next step on this issue? I guess it is for me to configure the lenny buildslaves to build a .deb.

comment:3 Changed at 2009-10-26T20:33:53Z by zooko

I linked to this ticket from DownloadDebianPackages.

comment:4 Changed at 2009-10-26T20:34:05Z by zooko

  • Milestone changed from 1.5.1 to eventually

comment:5 Changed at 2011-07-22T20:31:59Z by davidsarah

  • Resolution set to invalid
  • Status changed from assigned to closed

The current Debian and Ubuntu packages don't need to depend on a separate package for sqlite because it's included in Python >= 2.5.

Note: See TracTickets for help on using tickets.